Movabletype 3.11-ja アップグレードではまった点

Movabletype 3.11-ja のアップグレードは比較的簡単でしたが、少しはまった点を紹介します。

アップグレードの方法はMilano::Monologを参考にしそのとおり行いました。はまった点は \mt\pluginsにsub_cat.plが既にインストールされていたため再定義エラーになりサブカテゴリがうまく実行されなかったことです。3.11aからはサブカテゴリの機能が標準で搭載されているので、sub_cat.plは必要ありません。それを削除したら問題なく動きました。

なお、このエラーはmt-upgrade30.cgi、mt-upgrade31.cgiを実行すると表示されます。

コメントを残す

メールアドレスが公開されることはありません。